Hexagon Geospatial
MENU

M.App Enterprise

Discuss topics with other M.App Enterprise Product pioneers and experts to get the most out of it.
Showing results for 
Search instead for 
Do you mean 
Reply
Frequent Contributor
Posts: 143
Registered: ‎04-29-2016

Wrong Image Path! at Default Print Layout (With Legend)

Hi,

 

How to set logo to the Default Print Layout (With Legend) at the desktop application. as it display "Wrong Image Path!" message.

 

Regards,

Maha

Staff
Posts: 1,036
Registered: ‎10-18-2015

Re: Wrong Image Path! at Default Print Layout (With Legend)

Hi,

 

it's normal to see that message in the print layout itself. The way to bind the image to the layout is done afterwards in the administrator. You have to go to printlayouts -> select the one you want to use -> print values -> select project -> edit logo settings (which is one of the variables available from the print layout definition):

 

Capture.PNG

HTH,

Stefano

Stefano Turcato
Presale Engineer
Hexagon Geospatial
Frequent Contributor
Posts: 143
Registered: ‎04-29-2016

Re: Wrong Image Path! at Default Print Layout (With Legend)

Hi,

 

Yes, this can be done at Smart Client as indicated by snapshots.

Iam asking how to do the same at M.App Enterprise?? 

Note: my question is at M.App Enterprise support Section

 

Regards,

Maha

Staff
Posts: 1,036
Registered: ‎10-18-2015

Re: Wrong Image Path! at Default Print Layout (With Legend)

sorry, my fault. This is not supported. 

The plan is to have a different printing engine, so several changes might happen in future releases.

 

Stefano

Stefano Turcato
Presale Engineer
Hexagon Geospatial
Frequent Contributor
Posts: 147
Registered: ‎03-04-2016

Re: Wrong Image Path! at Default Print Layout (With Legend)

Not directly related but is it normal to only have the feature name in legend and not detailed classification when that exists?

 

Because i can't get the legend to be fully displayed with this layout (or my own layout for that matter).

 

I tried to use the Feature Icon legend instead but if i remember correctly, you use one icon for a feature. Is that correct?

i'm missing guidance and i can't find how to do it in the documentation.

Also, when i change the color, it goes back to black so no way to define my own legend with the Feature Icon.

 

Elodie

Staff
Posts: 1,036
Registered: ‎10-18-2015

Re: Wrong Image Path! at Default Print Layout (With Legend)

Hi Elodie,

 

it's a bug, already tracked down.

 

Stefano

Stefano Turcato
Presale Engineer
Hexagon Geospatial
Frequent Contributor
Posts: 147
Registered: ‎03-04-2016

Re: Wrong Image Path! at Default Print Layout (With Legend)

Thanks for the reply Stefano.

 

Here's to hoping it will be fixed in the next release.

 

Elodie

Technical Evangelist
Posts: 178
Registered: ‎03-03-2016

Re: Wrong Image Path! at Default Print Layout (With Legend)

[ Edited ]

Hi Maha,

 

it's not working via Studio like in GMSC but images are of course still supported in print layouts.

I've attached some instructions how to do it.

 

Basically the image must be accessible from a URL ... that's all. 

 

Hope that helps,

Thomas

Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Development Ticket through our Development Ticket Portal.