Smart M.App discussions

Looking for answers in regards to M.Apps, M.App Exchange or M.App Studio? Smart M.App Tech Discussion board is where you can search, ask your questions and assist others by sharing your knowledge. Join the conversation, connect, contribute and share.
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Occasional Contributor
Posts: 8
Registered: ‎12-11-2016

Custom table input error

Dear All,

 

I tried to add a column called "color". The color values from custom table input. 

Then I got the errors like show in the picture: 

 

Could you tell me please, how to fix this?

 

Thanks

Siline

custom.JPG

 

 

Technical Evangelist
Posts: 130
Registered: ‎07-04-2016

Re: Custom table input error

Hello Siline,

 

I was able to reproduce your error only with following steps:

 

1. Firstly validated model with empty data on Value port in Custom Table Input operator.

 

1.png

 

2. Then added values and model was validated with an error. BUT still even with this validation error, the model execution was successful. 

 

2.png 

3. Probably it wasn't updated in time. Then I've checked/unchecked the Value port. And model was validated. Also tried to remove and place again Custom Table Input with values.

 

3.png

 

Please, try it and let me know if it works for you.

 

If not, tell me your steps to reproduce the issue. Or export model and send to me.

 

 

Kind Regards,

Marina Vardovska

Hexagon Geospatial Support

Kind Regards,
Marina Vardovska
Hexagon Geospatial Support
Technical Evangelist
Posts: 130
Registered: ‎07-04-2016

Re: Custom table input error

This strange behavior is already fixed and will not disturb users with the next update soon.

 

Kind Regards,

Marina Vardovska

Hexagon Geospatial Support

Kind Regards,
Marina Vardovska
Hexagon Geospatial Support