Smart M.App discussions

Looking for answers in regards to M.Apps, M.App Exchange or M.App Studio? Smart M.App Tech Discussion board is where you can search, ask your questions and assist others by sharing your knowledge. Join the conversation, connect, contribute and share.
Showing results for 
Search instead for 
Do you mean 
Reply
Occasional Contributor
Posts: 14
Registered: ‎11-21-2017

IA not Saving view when you add boundary data file

Hi Robert/ Team,

 

I am developing a demo for a client to showcase the power of the Feature Analyzer products using the Incident Analyzer. The view works well until you add a boundary data file thst shoes buffer zones for their services/ or boundary data of the administrative units. The bounday information loads but the view will not save ... though of course it indicates that the view is saved although the progress bar does not load completely. Is there a bug or is it because i am not using the latest update? see screen shot below

 

IA.png

Kind regards

 

Antony

Technical Evangelist
Posts: 35
Registered: ‎07-12-2016

Re: IA not Saving view when you add boundary data file

Dear Antony,

 

Sorry to hear that you are having some issues with properly saving your view. Let’s see if we can determine what the issues might be.

 

Questions:

  • Would it be possible to share the data with me (i.e. sent the data sources for the Feature Data and the Boundary Data)?  
  • Also would it be possible to send me the Template file for this view. To create a Template file, please use the following workflow.

 

Create a Template:

  • Launch Incident Analyzer.
  • Open the view (you are having issues with) in Configuration mode.
  • Open the Sidebar panel.
  • Open the Export area.
  • Choose View Template.

 

With these materials, I can try to replicate the issue here on my instance and report my findings.

 

Sincerely,

Robert

 

Frequent Contributor
Posts: 119
Registered: ‎04-05-2016

Re: IA not Saving view when you add boundary data file

Hello,

 

It's always a good idea to open development tools (F12) of your browser and have a look in the console for any error messages or warnings. Have you tried that during the saving progress bar being stuck?

 

Regards,

Sven

Occasional Contributor
Posts: 14
Registered: ‎11-21-2017

Re: IA not Saving view when you add boundary data file

Hi Robert,

 

Thanks for the prompt response. I am attaching the csv with attribute data and the 2 boundary files i was trying to work with (topojson and geojson)

 

Separately, i am not getting the export option for the templates. I will inbox you my credentials to M.App Exchange and you can check this out. 

Technical Evangelist
Posts: 35
Registered: ‎07-12-2016

Re: IA not Saving view when you add boundary data file

Hello,

 

Thank you for the information. I have had a look at your data and have a couple of updates and questions.

 

Updates:

 

  1. I used the data you provided and your account to test.
  2. I was able to create and save a view using the data you provided.
  3. The view I created is called Test Robert.
  4. Have a look at this.

 

Questions:

 

  1. I used Chrome to create this view, what Browser were you trying.
  2. There are slight differences between browsers so this may be the root of the issue

 

More Updates:

 

  1. I also noted that you were using the B2B platform for this work.
  2. We are in the process of updating this platform with the latest and greatest versions of the Smart M.App that make up the M.App Analyzer Suite.
  3. The M.App Analyzer Suite of Smart M.Apps included (Incident Analyzer, Area Analyzer, Network Analyzer, Analyzer Viewer, and Feature Analyzer, Feature Analyzer for M.App Enterprise).
  4. I have attached the release notes so that you can get a feel for the updates.
  5. Massive improvements through-out all of the M.Apps.

 

Anyway, I hope this helps.

 

Sincerely,

Robert

 

 

Occasional Contributor
Posts: 14
Registered: ‎11-21-2017

Re: IA not Saving view when you add boundary data file

Dear Robert, 

 

Thanks for the prompt feedback. Yes we are using the B2B platform to develop demos as a way of selling the concept to the client. I had also picked up the issue with our RM as i noted that the Feature Analyser Kit on the B2B is not the latest.

 

i am also developing on chrome browser. I have actually copied the template you were using and i have noted that i can add charts as necessary. However, when i load the theme field, all the points on the map disappear and any further changes become unresponsive. Of course i would prefer the theme field to work as i can add additional themes instead of having many charts displayed.

 

Actually this problem is a bit unique as i have never encountered it before. I will test on a different browser and revert.

 

Kind regards

 

Antony

Technical Evangelist
Posts: 25
Registered: ‎05-12-2016

Re: IA not Saving view when you add boundary data file

Anotony,

 

We have updated all the Analyzer apps on the B2B to the latest version. Let us know if this is still an issue.

 

Thanks,

 

Dave