Smart M.App discussions

Looking for answers in regards to M.Apps, M.App Exchange or M.App Studio? Smart M.App Tech Discussion board is where you can search, ask your questions and assist others by sharing your knowledge. Join the conversation, connect, contribute and share.
Showing results for 
Search instead for 
Do you mean 
Frequent Contributor
Posts: 134
Registered: ‎04-11-2016
Accepted Solution

Spatial recipes are not recognized in creation page

Hi team


I created a couple of spatial recipes in M.App studio, consumed them M.Apps, they worked fine until I wanted to have a play with the IMAGINE spatial model publishing feature.

I created a simple spatial model in IMAGINE, managed to publish it to M.App and it became discoverable in M.App right after the publish (which is cool). Then I manually removed the other recipes that I created previously just to keep the one that published from IMAGINE.Then I wanted to create a new M.App using this spatial recipe and I couln't see it in the spatial recipe list, all I could see was one of the spatial recipes that I had removed previously.

I tried to clear the browser cache, logged off and logged back in, didin't make any changes.


Any one has observed the same issue?




Frequent Contributor
Posts: 106
Registered: ‎06-03-2016

Re: Spatial recipes are not recognized in creation page



When you save a recipe in the Spatial Modeler, it is not automatically visible in M.App Studio.


[1] After saving, click on your recipe in the Saved list (left panel), then click the Publish button (top right).




[2] You'll now see your recipe appear under the Published drop-down/accordian (again, left panel).



[3] And now you'll be able to see your recipe in M.App Studio.