Hexagon Geospatial

Smart M.App

Looking for answers in regards to M.Apps, M.App Exchange or M.App Studio? Smart M.App Tech Discussion board is where you can search, ask your questions and assist others by sharing your knowledge. Join the conversation, connect, contribute and share.
Showing results for 
Search instead for 
Do you mean 
Posts: 33
Registered: ‎10-26-2015

Create Geospatial PDF - no vector in output


Is there any example using "Create Geospatial PDF" Operator in Spatial Workshop? I've done several testing. Always with the following input:

  • 1 raster (tiff)
  • 1 Vector (shp)

I get a pdf as a result with 3 layers:

  • boundary
  • my raster
  • my vector

But only the rasterfile is desplayed in the pdf. The vector layer has no content.


I've tryed to provide the shp-file either directly over port input to "Create Geospatial PDF" Operator (OverlayList) or via a Dictionary. Both with the same result. I've no EVS available.


Any hints?

Thanks, Luzius


(I've posted this message also in Support M.App Enterprise, but actually it is happenning in Smart M.App Environment)

Posts: 3
Registered: ‎11-16-2016

Re: Create Geospatial PDF - no vector in output

[ Edited ]



It worked for me on 16.1 Spatial Modeler using IMAGINE product. Which version of Spatial Modeler is used in Spatial Workshop you are working with? Have you retried your workflow with the latest Spatial Workshop? Maybe it is a data specific problem. Have you tried other datasets? Is it possible for you to give us your raster and vector data so we can reproduce the problem?






Posts: 3
Registered: ‎11-16-2016

Re: Create Geospatial PDF - no vector in output

[ Edited ]

The image attachment did not work last time. Try it again.

Do you need immediate support?
Please submit a Ticket through our
Development Ticket Portal.