Hexagon Geospatial
MENU

Smart M.App

Looking for answers in regards to M.Apps, M.App Exchange or M.App Studio? Smart M.App Tech Discussion board is where you can search, ask your questions and assist others by sharing your knowledge. Join the conversation, connect, contribute and share.
Showing results for 
Search instead for 
Do you mean 
Reply
Frequent Contributor
Posts: 107
Registered: ‎10-16-2015
Accepted Solution

Lowest supported javascript version?

I was wondering: is it ok to use the ECMAScript 6 features in my Smart M.Apps? I've noticed that the gsp API is using Promise, so apparently gsp is using ES6 too, so there's no reason to aim any lower.

Technical Evangelist
Posts: 1,093
Registered: ‎09-11-2015

Re: Lowest supported javascript version?

Hi Arjen,

 

I might not be a best expert on this but isn't it a matter of which web browser the users have? I've found this nice table showing which components are supported by standard web browsers:

http://kangax.github.io/compat-table/es6/

 

Regards,

Jan

Jan Neumann
Post Sales Engineer Web Applications
Hexagon Geospatial

Frequent Contributor
Posts: 107
Registered: ‎10-16-2015

Re: Lowest supported javascript version?

let me rephrase: which browser-versions are supported by Smart M.Apps? Does Smart M.Apps use es6 constructs that are not supported by e.g. IE11?

Highlighted
Technical Evangelist
Posts: 1,093
Registered: ‎09-11-2015

Re: Lowest supported javascript version?

This is what I found in the documentation:

 

Supported Web Browsers

M.App Chest and M.App Studio run in the following browsers.

  • Microsoft Edge
  • Internet Explorer 11
  • Google Chrome
  • Mozilla Firefox

Apple Safari and Internet Explorer 10 are not supported.

Smart M.Apps created using M.App Studio run in the following browsers.

  • Microsoft Edge
  • Internet Explorer 11
  • Google Chrome
  • Mozilla Firefox
  • Apple Safari

---

No clear version specified for others than IE but the development team probably always use one of the latest versions. Chrome and Firefox update themselves automatically and very often.

 

Jan

Jan Neumann
Post Sales Engineer Web Applications
Hexagon Geospatial

Frequent Contributor
Posts: 107
Registered: ‎10-16-2015

Re: Lowest supported javascript version?

Too bad IE11 is in this list. This rules out a lot of ES6 constructs that I can use :-(

Technical Evangelist
Posts: 1,093
Registered: ‎09-11-2015

Re: Lowest supported javascript version?

I see what you mean but having broader browser compatibility will have always a priority than option of having modern fancy code constructs.

 

Jan

Jan Neumann
Post Sales Engineer Web Applications
Hexagon Geospatial

Do you need immediate support?
Please submit a Ticket through our
Development Ticket Portal.