Hexagon Geospatial
MENU

Smart M.App

Looking for answers in regards to M.Apps, M.App Exchange or M.App Studio? Smart M.App Tech Discussion board is where you can search, ask your questions and assist others by sharing your knowledge. Join the conversation, connect, contribute and share.
Showing results for 
Search instead for 
Do you mean 
Reply
Frequent Contributor
Posts: 77
Registered: ‎10-12-2015
Accepted Solution

Spatial model does not output features

I have a spatial model that's (among other things) supposed to take a shp file, add two attributes to it and then output it. The spatial recipe also does some things with two rasters. The rasters show up just fine, however, the features don't see the light of the day. I'll put a download link to the model here: http://s000.tinyupload.com/?file_id=09507784542920988090 (because I still have no idea if I can directly upload files here, so sorry).

Frequent Contributor
Posts: 77
Registered: ‎10-12-2015

Re: Spatial model does not output features

[ Edited ]

lI have created a much simpler model which does the same things that the other one does: 

 

 

I tested it, and it didn't want to finish running - it stopped at "publishing item". Now, I know that, in the mapp chest, features can't be published, so this was certainly unexpected. How cn a model actually be able to receive features as input and then output them to the chest? (Mind you, both of these models work flawlessly in Erdas IMAGINE)

Frequent Contributor
Posts: 77
Registered: ‎10-12-2015

Re: Spatial model does not output features

Got it working by placing a "file input" inbatween the port input and features input. Now it works.

Do you need immediate support?
Please submit a Ticket through our
Development Ticket Portal.