Hexagon Geospatial

Spatial Modeler

Discuss topics with other Hexagon Geospatial Product pioneers and experts to get the most out of our products.
Showing results for 
Search instead for 
Do you mean 
Occasional Contributor
Posts: 11
Registered: ‎01-06-2016

Spatial Model problem

[ Edited ]

Dear All,


I am writing to consult you the problem i have encountered in spatial modeler, I have a simple model of layer stacking images that only asks for 7 input bands (Landsat Images) and the output image file. 

The model works fine in the spatial model editor however after adding and launching it via My Models it doesn't work anymore, but if you open it in the Spatial model editor it works again. 

I checked the session log and below is the identified problem,


1/11/16 12:14:03 SessionMgr(9540): HexGeo:SpatialModeler:Operator::Execute failed
01/11/16 12:14:03 HexGeo:SpatialModeler:Operator::Execute failed
01/11/16 12:14:03 HexGeo:SpatialModeler:Operator::Execute failed
01/11/16 12:14:03 HexGeo:SpatialModeler:Operator::Execute failed
01/11/16 12:14:03 HexGeo:SpatialModeler:Operator:SetErrorMessage failed
01/11/16 12:14:03 Spatial Model failed in Raster Input. The error was "No input file available".
01/11/16 12:14:03 SessionMgr(9540): Spatial model failed.
01/11/16 12:14:03
01/11/16 12:14:03 SessionMgr(9540): smprocess.exe exited with status 1.

I noticed the error was "No input file available" so I tried to fill the model in the spatial model editor with the input data and output name and saved it as My model, I launched the model and the I/O are already populated with data, I ran the model and it worked, then i tried another run this time with a different data and it worked again. However, after clearing/removing the data in the spatial model editor and saving it again as a new model , the model doesn't work again.


Hope you could enlighten me with this. Thank you in advance. 

Best regards,


Technical Evangelist
Posts: 772
Registered: ‎10-01-2015

Re: Spatial Model problem

[ Edited ]

Hi Liz,


Do you have the data types set correctly in your Port Input operators? Without seeing the actual model I'm just guessing at possible problems.


BTW - the screenshot at the bottom of this Spatial Recipe article shows the approach I took to layer-stacking Landsat band files (based on a standardised input naming convention): http://community.hexagongeospatial.com/t5/Spatial-Recipes/Commandline-Iterator-Extract-Landsat-TarGz...




Ian Anderson
Chief Product Owner, Desktop Remote Sensing
Hexagon Geospatial
Frequent Contributor
Posts: 153
Registered: ‎10-27-2015

Re: Spatial Model problem

Indeed - we have had similar issues when developed model is transferred to another computer and tried to run there. It requires certain settings for ports and empty input files before it is runnable in another environment. The error messages you get are coming from files used in development state and not available in end user environment.


This is something that is not so well documented so for us it was trial and error procedure before it worked.



Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Service Request through our Support Portal.