WebGIS Discussions

Need a push in the right direction when configuring WebMap, Portal or SDI services? Looking for hints and tips, or just looking for Ideas and information? The WebGIS discussion board is where you start those discussions, connect and share information.
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Staff
Posts: 28
Registered: ‎08-29-2018

Error creating 3D objects in mTransformer

[ Edited ]

Hello all, 

 

I am trying to create a 3D objects service using our mTransformer v2018 and it should render in geospatial portal. 

 

My input file is kml which has a referenced .dae 3D model in it. I have checked the kml file structure which exactly the same in the help document. And .dae 3D buiding model is a georeferenced one and also textured using img files.

 

So when i use those kml in mtransformer, my conversion got crashed and ends with exit code -1073741819

 

Attached screenshots the same. 

 

can anyone please suggest ideas for possible outcomes? am not finding out where would be issue. 

 

or please suggest any other methods for creating 3D objects service using mtransformer to render in geospatial portal.

 

Thanks.

 

Regards, 

Karthik 

Highlighted
Technical Evangelist
Posts: 968
Registered: ‎07-30-2015

Re: Error creating 3D objects in mTransformer

Hi Karthik,

 

I don't think mTransformer is Apollo or ECW related product, please post your question in WebGIS forum if possible.

 

Thanks & best regards!
haiyan

Highlighted
Staff
Posts: 28
Registered: ‎08-29-2018

Re: Error creating 3D objects in mTransformer

Thanks haiyan. I moved into webgis discussions. 

 

So anyone please provide me the possible outcomes to my issue mentioned above.

 

Thanks. 

 

Regards, 

Karthik, 

Highlighted
Technical Evangelist
Posts: 1,372
Registered: ‎09-11-2015

Re: Error creating 3D objects in mTransformer

Hi Karthik,

 

Can you make sure the .DAE file is present in the specified location in KML?

 

Could you perhaps try to validate the DAE file? I have no experiences here, but I found this how-to link:

https://www.khronos.org/collada/wiki/Schema_validation

Jan Neumann
Post Sales Engineer Web Applications
Hexagon Geospatial

Highlighted
Staff
Posts: 28
Registered: ‎08-29-2018

Re: Error creating 3D objects in mTransformer

[ Edited ]

Hi jan,

 

Thanks for the reply. Pls find my observations below,

 

  1. yes. .dae file is present exactly the same position in kml. 
  2. I have tried those schema validation for .dae file. But it get fails. Attached the screenshot. 

FYI, I did some alternatives on this, 

 

I have converted .dae file into .obj file and run the process in mtransformer with the location specified csv file used

This time, the process ran successfully. I have used those output (source.json) in portal, but nothing shows in portal. 

 

Attached screenshots of same and csv files used. 

 

Please suggest for possible outcomes. 

 

Regards, 

Karthik. 

CSV location file used