WebGIS Discussions

Need a push in the right direction when configuring WebMap, Portal or SDI services? Looking for hints and tips, or just looking for Ideas and information? The WebGIS discussion board is where you start those discussions, connect and share information.
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
New Contributor
Posts: 2
Registered: ‎10-25-2017

Legends in WMPS

[ Edited ]

Dear collegues:

 

We have suddenly experienced a problem connecting a wmps service: No legend is displayed. They were displayed without problems before a minor legend modification (assign a tooltip field) .

 

In Geomedia WebMap Administrator, all legends are still seen correctly for that application.

 

In the log file of the wmps service, we can see the following error:

2018-09-26 11: 35: 10,837 [13] ERROR Session Identifier: urn: uuid: 632ce41f-2781-4f71-9cf4-c5b10a6a8263 message: Error Get Legend by Application Id: MYAPPLICATION. Error message: The RPC server is unavailable. (Exception from HRESULT: 0x800706BA) - {Intergraph.WebSolutions.Core.MapPublisherConnector.Service.Legend}

 

We have reviewed the RPC service on that server and it is running (started automatic). We have repeated the test from the same server and the result is still the same.

 

It seems that the WMPS service, when it is caching, does not generate any legend information in the capabilities.xml file now. The rest of the file seems correct and all the features classes are included and displayed correctly in Geospatial Portal. But we have no idea about the cause.

 

The only line about legends in that file now is the following (no legends):

<Legends xmlns:a="http://schemas.microsoft.com/2003/10/Serialization/Arrays"/>

 

As I say, it has been a totally sudden behavior. It has stopped working after a simple modification in one of the legends. If we reverse the modification, it still does not work.

 

Does anyone know what may be happening?

 

Environment:

OS: Windows 2012 R2

Database storage: Oracle 12c

Geomedia Webmap version: 16.00.02

Geospatial portal: 16.00.0200

 

Thank you in advance.

Highlighted
Regular Contributor
Posts: 218
Registered: ‎07-27-2016

Re: Legends in WMPS

Hi fsanchezb,

 

Did you ever managed to solve the problem.

Having the same problem only different server and webmap version.

Cache and xml was fine, nothing changed, been working like this for months and then all of a sudden this happens.

everything looks fine, cache images does not build and xml is missing legend info.

 

Kind regards

jacques

Highlighted
New Contributor
Posts: 2
Registered: ‎10-25-2017

Re: Legends in WMPS

Hi, Jacques.

 

It may seem incredible but we managed to solve it  by truncating 4 large Oracle tables (over 5 million records each). These tables were used in 4 legend entries but lately the number of records had increased a lot (it's the only explanation we found).

 

After that, the capabilities files was generated correctly (with all legend info) and everithing worked again. (Maybe some error in the dll that generates the capabilities file in the cache?) When the cache is already generated, the tables can have all the information again and they are displayed correctly in Geospatial Portal.

 

This has a tedious dependency: every time we make a change in WebMap, we have to temporarily empty those 4 tables until the cache has been generated.


Unfortunately we have no response from Intergraph so far.

I hope this helps you.

 

Regards