WebGIS Discussions

Need a push in the right direction when configuring WebMap, Portal or SDI services? Looking for hints and tips, or just looking for Ideas and information? The WebGIS discussion board is where you start those discussions, connect and share information.
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Contributor
Posts: 37
Registered: ‎10-07-2019
Accepted Solution

Map Service HTTPS issue

Hi All,

 

I have published a WMS map service in webmap and i have setup hostname settings in Admin Console to the domain name and port 443. When I run the map service with this URL, I get error shown below:

 

====================

 

https://skhighwaygis.saskatchewan.ca/del1/Service.svc/get?request=GetCapabilities&service=WMS

 

 

Server Error in '/del1' Application.


The resource cannot be found.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly.

Requested URL: /del1/service.svc/get


Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.7.3062.0

 

====================

 

 

If I access that map service with localhost or machine name on the same computer then it works as expected. 

http://[machine name or localhost]/del1/Service.svc/get?request=GetCapabilities&service=WMS

 

How can I fix this issue? 

 

Thank you,

 

Muhammad Almas

Highlighted
Technical Evangelist
Posts: 1,238
Registered: ‎09-11-2015

Re: Map Service HTTPS issue

Hi Muhammad,

 

Did you change the WMS web.config to accept incoming HTTPS requests? You must change <serviceBehaviors> and <webHttpBinding> sections as outlined here:

https://hexagongeospatial.fluidtopics.net/reader/nnybR~tZxbDITXWj2GgNxQ/U_1QrndqIXEB9u~zEaNZ3w

Jan Neumann
Post Sales Engineer Web Applications
Hexagon Geospatial

Highlighted
Contributor
Posts: 37
Registered: ‎10-07-2019

Re: Map Service HTTPS issue

Thank you very much Jan. This solution worked, but there is one additional step that I had to do and that is to enable 'HTTP Activation' and 'Non-HTTP Activation' in server features as shown below. 

 

features_server.PNG