WebGIS Discussions

Need a push in the right direction when configuring WebMap, Portal or SDI services? Looking for hints and tips, or just looking for Ideas and information? The WebGIS discussion board is where you start those discussions, connect and share information.
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Contributor
Posts: 39
Registered: ‎05-09-2017

WFS service

Hello!

There is a working WFS service. Made changes to the attributes of the obgect, the service was re-published and connected to the portal. The data has not been update. The cache was cleaned. The service was restarted.

What could be the reason?

Anna
Highlighted
Technical Evangelist
Posts: 401
Registered: ‎02-04-2016

Re: WFS service

Hi Anna,

 

Does the new getcapabilities request reflect the updated attribute info ? If so, you may want to try it on  a different portal instance or in GeoMedia to see if that makes any difference.

 

Thanks

 

Frank

Highlighted
Contributor
Posts: 39
Registered: ‎05-09-2017

Re: WFS service

Hi, Frank!

Getcapabilities does not reflect attribute information. Connected to another portal, new attributes are not reflected. In GM attributes are displayed.

Anna
Highlighted
Technical Evangelist
Posts: 401
Registered: ‎02-04-2016

Re: WFS service

Hi Anna,

 

Could you provide more details on the changes you have done to the WFS attributes ?

 

Are you modifying the Feature class > Fields information (i.e. Exclude field or change Alias of the field) through WebMap Publisher Administrator's [Miscellaneous>Display Fields] command ?

 

So you are saying under portal, the updated attributes are not showing whereas in GM (i.e. with WFS GDO connection) the updated attributes are displaying correctly ?  That is odd...

 

Thanks

 

Frank

Highlighted
Contributor
Posts: 39
Registered: ‎05-09-2017

Re: WFS service

Hi Frank,

In GM in Feature class  I add lines to attributes, in [Miscellaneous>Display Fields]  the checkboxes of attributes are, there I do not change anything. It only helps to transfer to another Feature class and republish it.

That is  very odd...

Anna
Highlighted
Technical Evangelist
Posts: 401
Registered: ‎02-04-2016

Re: WFS service

Hi Anna,

 

Could you attach some screenshots?  Still trying to understand what you were describing...

 

Thanks 

Frank

Highlighted
Contributor
Posts: 39
Registered: ‎05-09-2017

Re: WFS service

Hi Frank,

I filled in several attributes and the changes were reflected in the portal.

Thank you for participating

 

Anna
Highlighted
Technical Evangelist
Posts: 401
Registered: ‎02-04-2016

Re: WFS service

Hi Anna,

 

So I assume everything is working as expected now ?

 

Thanks

 

Frank