WebGIS Discussions

Need a push in the right direction when configuring WebMap, Portal or SDI services? Looking for hints and tips, or just looking for Ideas and information? The WebGIS discussion board is where you start those discussions, connect and share information.
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Regular Contributor
Posts: 230
Registered: ‎07-27-2016

WMS Tempral Time Series

Hi All,

 

Can someone please help me regarding creating a temporal time series wms.

I have some vector area weather data within SQL Server 2016.

I have created a wms service in webmap and created a straight forward geomedia workspace for it.

On the publisher legend options I added the temporal time series options.

When adding the wms service in geospatial portal and tring to display the data , or making changes to the date I get the following error displayed in portal:

 

Error: Service name: 'Hexagon Geospatial OGC Web Map Service' has returned document in invalid format.

 

I get no errors in the portal log or the wms log.

 

If I remove the temporal time series options in publisher the wms works fine.

 

Any idea what can cause this issue , or where I can get a more detailed error than this?

 

Kind Regards

Jacques

Highlighted
Regular Contributor
Posts: 230
Registered: ‎07-27-2016

Re: WMS Tempral Time Series

Hi All,

 

When temporal time series is enable I get this in GWMLog.

 

2020-06-17 12:20:56 (0.724236) - Publisher: LegendEntryServices: GetLegendEntries : Applying a spatial filter from passed objASFSW
2020-06-17 12:20:56 (0.724296) - GWMServices: ASFSW :ApplySpatialFilterToLegendEntry: Starting
2020-06-17 12:20:56 (0.754424) - GWMServices: ASFSW :ApplySpatialFilterToLegendEntry: Exiting
2020-06-17 12:20:56 (0.755230) - Publisher: LegendEntryServices: ApplyTemporalFilter : Begin
2020-06-17 12:20:56 (0.755613) - Publisher: LegendEntryServices: ApplyTemporalFilter : Getting temporal filter
2020-06-17 12:20:56 (0.755794) - Publisher: LegendEntryServices: ApplyTemporalFilter : Applying temporal filter case 1 Filter =Impact_DateTime = TIMESTAMP '2018-01-01 00:00:00'
2020-06-17 12:20:56 (0.755882) - Publisher: LegendEntryServices: ApplyTemporalFilter : WMSTimeWarnings defaulttime::2018-01-01 00:00:00;;name::Cultivated_HailImpact
2020-06-17 12:20:56 (0.756062) - Publisher: LegendEntryServices: GetLegendEntries : Opening the Recordset
2020-06-17 12:20:56 (0.768738) - Publisher: LegendEntryServices: ERROR: Number: 0x80040E14; Description: GetLegendEntries: Method '~' of object '~' failed; Source: GWMPub
2020-06-17 12:20:56 (0.769296) - Publisher: WebServicesUtilities: GetLegendEntry : EXIT
2020-06-17 12:20:56 (0.769600) - GMWS: Error - GetLegendEntry: GetLegendEntries: Method '~' of object '~' failed
2020-06-17 12:20:56 (0.769715) - GMWS: Error - (null)
2020-06-17 12:20:56 (0.769747) - GMWS: Exit MapURL -2147467261 (80004003)

Highlighted
Regular Contributor
Posts: 230
Registered: ‎07-27-2016

Re: WMS Tempral Time Series

[ Edited ]

Webmap version 16.5 Ep02

Highlighted
Technical Evangelist
Posts: 402
Registered: ‎02-04-2016

Re: WMS Tempral Time Series

Hi Jacques,

 

Error 0x80040E14 may point to 'invalid column name', could you check the GM metadata to make sure they are correct.

 

Btw, WMS-T has been pretty stable since the v15 days...

 

Thanks

 

Frank

Highlighted
Regular Contributor
Posts: 230
Registered: ‎07-27-2016

Re: WMS Tempral Time Series

Hi Frank,

Thanks for the response.

Yes I had a look at WMSTEMPORALMEASUREMENTFIELD and it contains the correct field value.

 

Kind Regards

Jacques

 

 

Highlighted
Technical Evangelist
Posts: 402
Registered: ‎02-04-2016

Re: WMS Tempral Time Series

Hi Jacque,

 

What is so special about this field coming from MSSQL 2016??

 

Do you know if the WMS GetFeatureInfo will display this field correctly (under Portal) ?

 

You may try export a small subset to Access warehouse and try to replicate (eventually...Support would like to play with that too Smiley Happy )

 

Thanks

 

Frank

Highlighted
Regular Contributor
Posts: 230
Registered: ‎07-27-2016

Re: WMS Tempral Time Series

Hi Frank,

 

Thanks for the reply.

Not sure I follow you regarding the MSSQL field, it is a normal datetime field.

The wms service works fine when now temporal is added , all features and attributes are displayed correctly , only gets the issue when a temporal field is defined.

 

We have opened a support ticket and Pavel is looking into it.

I have given him a full backup of the database.

 

Kind Regards

Jacques

Highlighted
Technical Evangelist
Posts: 402
Registered: ‎02-04-2016

Re: WMS Tempral Time Series

Hi Jacque,

 

I just wanted to make sure the datetime field can be displayed properly, so the WMS-T issue seems to point to the setup process...

 

Thanks

 

Frank

Highlighted
Regular Contributor
Posts: 230
Registered: ‎07-27-2016

Re: WMS Tempral Time Series

Hi Frank,

 

Again, thanks for the reply.

I gave Pavel a copy of our database,he tested it and could replicate the issue.He did log a bug report.

So we are waiting for feedback.

 

Kind Regards

Jacques