WebGIS Discussions

Need a push in the right direction when configuring WebMap, Portal or SDI services? Looking for hints and tips, or just looking for Ideas and information? The WebGIS discussion board is where you start those discussions, connect and share information.
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Occasional Contributor
Posts: 8
Registered: ‎01-21-2019

Webmap 2020 Consumer Portal does not honour the Display Field settings in WMPS administrator

I have hidden some of the fields in WMPS metadata using the Display Fields function in Webmap publisher.  Both the adminportal and the consumer portal use the same WMPS service, but the only the admin portal displays only the fields that are required but consumer portal displays all the information. 

 

The admin portal has fields hidden as defined in webmap administrator.

2020-03-12_16-21-58.png

 

The consumer portal has fields showing even though it should be hidden.

 

2020-03-12_16-22-05.png

 

 

Is there a way to configure Consumer Portal to hide some fields from the WMPS service?

Highlighted
Technical Evangelist
Posts: 1,382
Registered: ‎09-11-2015

Re: Webmap 2020 Consumer Portal does not honour the Display Field settings in WMPS administrator

Hi Winza,

 

I've just tried it using a new WMPS service + WMPS service source and both Geospatial Portal and Consumer Portal display only the fields defined in Display Fields.

 

Can you perhaps try to delete the WMPS cache folder?

(e.g. C:\Program Files\Common Files\Hexagon\Services\Instances\WMPS\cache)

 

Did you use "Display Maps" button, not the "Display feature classes and queries" in AdminPortal when setting up the workspace?

Jan Neumann
Post Sales Engineer Web Applications
Hexagon Geospatial

Highlighted
Occasional Contributor
Posts: 8
Registered: ‎01-21-2019

Re: Webmap 2020 Consumer Portal does not honour the Display Field settings in WMPS administrator

Hi Jan,

I tried to clear the WMPS cache many times but it didn't work.  And I have been using the Display Maps button in the AdminPortal.

Thanks,

Winza.

Highlighted
Technical Evangelist
Posts: 1,382
Registered: ‎09-11-2015

Re: Webmap 2020 Consumer Portal does not honour the Display Field settings in WMPS administrator

I've just done a couple of tests on another machine and still cannot reproduce the problem.

 

Here's what you can yet try if not done already:

  • restart WebMap and WWW service
  • clean up Temporary ASP.NET files
  • create a new workspace in AdminPortal, connect to the WMPS and publish it again to Consumer Portal
  • make sure that the WMPS url in Consumer's starting_wsp.json is correct
Jan Neumann
Post Sales Engineer Web Applications
Hexagon Geospatial

Highlighted
Occasional Contributor
Posts: 8
Registered: ‎01-21-2019

Re: Webmap 2020 Consumer Portal does not honour the Display Field settings in WMPS administrator

Hi Jan,

I have tried all the steps you listed but haven't had much success.  I even tried it with a new WMPS instance and metadata using SQLServer, and a new consumer portal instance.  But it is still not honouring the Display Field settings.

 

Winza

Highlighted
Super Contributor
Posts: 457
Registered: ‎10-12-2015

Re: Webmap 2020 Consumer Portal does not honour the Display Field settings in WMPS administrator

To replicate

    - Add feature 'water_valve' to legend, rename legend entry to 'Water Valve'

    - Sync legend

    - Use display fields to turn off fields for 'water_valve'

    - Use AdminPortal to assign WMPS legend to workspace, assign workspace to Consumer Portal

    - Launch Consumer Portal, observe 'Display Fields' is not honoured - fields removed via display fields are displayed. Observe geometry fields are listed as attributes.

 

I've logged ticket 00061437