WebGIS Discussions

Need a push in the right direction when configuring WebMap, Portal or SDI services? Looking for hints and tips, or just looking for Ideas and information? The WebGIS discussion board is where you start those discussions, connect and share information.
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Contributor
Posts: 37
Registered: ‎10-07-2019
Accepted Solution

running WMS error

I have just installed WebMap and created a WMs map service. When I run it, it takes a long time and I get following error.

 

=====================

Map Server Manager timed out waiting for a free Map Server
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Runtime.InteropServices.COMException: Map Server Manager timed out waiting for a free Map Server

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:


[COMException (0xa07b0001): Map Server Manager timed out waiting for a free Map Server]
Intergraph.GeoMedia.Web.MapSvrMngr.MapServerManagerClass.MapServer(String Session) +0
Intergraph.GeoMedia.Web.SDI.Common.AdvancedUtils.GWMServerHandle.GetWebMapServer(Boolean configureGWMCache, UInt16 poolID) +415
Intergraph.GeoMedia.Web.SDI.Common.AdvancedUtils.GWMServerHandle.CreateInstance(Boolean configureGWMCache, UInt16 poolID) +259
Intergraph.GeoMedia.Web.SDI.WMS.Pipes.WMSBasicOriginatingPipe.WMSBasicOriginatingPipe.InitializeDataSourceConfiguration() +52
Intergraph.GeoMedia.Web.SDI.WMS.Pipes.WMSBasicOriginatingPipe.WMSBasicOriginatingPipe.Initialize(PipeConfiguration config, IPipe nextPipe) +427
Intergraph.GeoMedia.Web.SDI.Common.BasePipe.PipesConfiguration.PipesManager.InitializePipe(String processedPipeName, IDictionary`2 sectionsMap, IDictionary`2 startedPipesSet, IDictionary`2 nextPipesMapping) +1169
Intergraph.GeoMedia.Web.SDI.Common.BasePipe.PipesConfiguration.PipesManager.InitializePipe(String processedPipeName, IDictionary`2 sectionsMap, IDictionary`2 startedPipesSet, IDictionary`2 nextPipesMapping) +1080
Intergraph.GeoMedia.Web.SDI.Common.BasePipe.PipesConfiguration.PipesManager.CreatePipes(ConfigurationSectionCollection sections) +1330
Intergraph.GeoMedia.Web.SDI.Common.SDIProFacadeInterface.WebPipesManager.CreatePipes() +420
Intergraph.GeoMedia.Web.SDI.Common.SDIProFacadeInterface.ConfigurationManager.CreatePipesManager() +661
Intergraph.GeoMedia.Web.SDI.Common.SDIProFacadeInterface.ConfigurationManager.Initialize(Uri serviceHostBaseAddress, ServiceEndpointCollection serviceEndpoints) +2092
Intergraph.GeoMedia.Web.SDI.Common.SDIProFacadeInterface.SDIProServiceBehaviorAttribute.Validate(ServiceDescription serviceDescription, ServiceHostBase serviceHostBase) +88
System.ServiceModel.Description.DispatcherBuilder.ValidateDescription(ServiceDescription description, ServiceHostBase serviceHost) +281
System.ServiceModel.Description.DispatcherBuilder.InitializeServiceHost(ServiceDescription description, ServiceHostBase serviceHost) +139
System.ServiceModel.ServiceHostBase.InitializeRuntime() +85
System.ServiceModel.ServiceHostBase.OnOpen(TimeSpan timeout) +48
System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout) +290
System.ServiceModel.HostingManager.ActivateService(ServiceActivationInfo serviceActivationInfo, EventTraceActivity eventTraceActivity) +129
System.ServiceModel.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath, EventTraceActivity eventTraceActivity) +731

[ServiceActivationException: The service '/HighwayOfficialCurrent/Service.svc' cannot be activated due to an exception during compilation. The exception message is: Map Server Manager timed out waiting for a free Map Server.]
System.Runtime.AsyncResult.End(IAsyncResult result) +607034
System.ServiceModel.Activation.HostedHttpRequestAsyncResult.End(IAsyncResult result) +231
System.Web.CallHandlerExecutionStep.InvokeEndHandler(IAsyncResult ar) +212
System.ServiceModel.Activation.HostedHttpRequestAsyncResult.End(IAsyncResult result) +231
System.Web.CallHandlerExecutionStep.InvokeEndHandler(IAsyncResult ar) +212
System.ServiceModel.Activation.HostedHttpRequestAsyncResult.End(IAsyncResult result) +231
System.Web.CallHandlerExecutionStep.InvokeEndHandler(IAsyncResult ar) +212
System.Web.CallHandlerExecutionStep.OnAsyncHandlerCompletion(IAsyncResult ar) +166


Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.7.3062.0\

===========================

 

How can it be fixed ?

Thanks,

 

Muhammad Almas

 

Highlighted
Technical Evangelist
Posts: 1,273
Registered: ‎09-11-2015

Re: running WMS error

Hi Muhammad,

  • Is this WebMap 2020?
  • Can you start WebMap service + can you run the Configuration Test sucessfully?
  • Is there a valid license?
  • Can you see any error in the Event Log viewer? (Application section)
Jan Neumann
Post Sales Engineer Web Applications
Hexagon Geospatial

Highlighted
Contributor
Posts: 37
Registered: ‎10-07-2019

Re: running WMS error

Hi Jan,

 

Yes it is WebMap 2020. License is valid.

I ran the configuration Test and got this error message.

 


GeoMedia WebMap Administrator Configuration Test

Error(s) occurred getting a MapServer object.
Possible reasons for this error include:

The necessary Distributed COM (DCOM) Security for users allowed Launch and Activation, and Access Permissions, especially regarding the IUSR (ASP) account, are not added for the GeoMedia WebMap Map Server Manager DCOM Application.

The Logon On account used to start and run the GeoMedia WebMap Serviceis not granted sufficient DCOM Permissions for the GeoMedia WebMap Map Server DCOM Application.

Review the System Security and Access Settings section in the online documentation.

The runtime error description follows:
MapSvrMngr_exe:The remote procedure call failed. (Exception from HRESULT: 0x800706BE)

Configuration Test executed on 2019-12-17 10:10:56 AM

 

How can I fix this error ?

 

Thanks,

 

Muhammad Almas

Highlighted
Technical Evangelist
Posts: 370
Registered: ‎02-04-2016

Re: running WMS error

Hi Muhammad,

 

Do you recall seeing all green check marks on the software prerequisites while running the WebMap Configuration Wizard ?

 

Do you recall running the WebMap setup.exe "As Administrator" ?  If not, I would try a reinstall (running the setup.exe As Admin)

 

Double click on the "GeoMedia WebMap" entry under the Control Panel > Admin Tools > Services interface, go to the "Log On' tab, are you using the default "Local System account" or a specific account to run the GeoMedia WebMap service ?

 

Thanks

 

Frank

 

 

Highlighted
Contributor
Posts: 37
Registered: ‎10-07-2019

Re: running WMS error

I am sorry guys, It was bad on my part. After installing WebMap neither I restarted the machine nor installer asked for it. I was getting errors due to that. Once I restarted the machine, everything is working as supposed to be.

 

Thank you for your support and help.

 

Regards,

 

Muhammad Almas

Highlighted
Technical Evangelist
Posts: 370
Registered: ‎02-04-2016

Re: running WMS error

Hi Muhammad,

 

Great to hear that!

 

Typically a restart is not required, but if you have multiple products installed, a reboot of the server would be recommended.

 

Thanks

 

Frank

Highlighted
New Contributor
Posts: 2
Registered: ‎12-20-2019

Re: running WMS error


@fmak wrote:

Hi Muhammad,

 

Great to hear that!

 

Typically a restart is not required, but if you have multiple products installed, a reboot of the server would be recommended.

 

Thanks

 

Frank


Yes it is WebMap 2020. License is valid.

I ran the configuration Test and got this error message.