Showing results for 
Search instead for 
Do you mean 

Google Maps is not enabled. Please contact your administrator.

by Technical Evangelist on ‎02-05-2016 12:03 PM - edited on ‎04-21-2017 06:25 AM by Technical Evangelist (506 Views)

Symptoms

When attempting to register or register and display Google Maps service in the Geospatial or Webmap Publisher Portal the user is met with the message "Google Maps is not enabled. Please contact your administrator" and the Google Maps data source is not registered. When the user reviews the Portal instance configuration via the Administration Console the Map Service Type of 'Google Maps' is shown as 'visible' by default. Why then is the Google Maps service not visible or enabled in the Portal?

Diagnosis

Users must declare conformance with Google Maps license agreements and terms of user before Google Maps services can be enabled in the Portal instance.

Solution

To resolve this the user is required to navigate to the 'web.config' file of the portal instance and set the 'GoogleMaps enabled tag value equal to 'true' as it is 'false' by default.

    By setting GoogleMaps enabled attribute to "true" you declare conformance with appropriate Google Maps license agreements and terms of use.

    For further information refer to:

    - http://www.google.com/help/terms_maps.html

    - https://developers.google.com/maps/licensing

    Google Maps API is enabled only when enabled is set to "true".

 

    For configuring Google Maps API Key (apiKey attribute) refer to https://developers.google.com/maps/signup

    -->

    <GoogleMaps enabled="true" apiKey="" />