Hexagon Geospatial
MENU

WebGIS Q&A

WebGIS enables powerful geospatial web applications and services that securely share your organization’s rich geospatial data, and provides tools to deeply examine spatial data and create value added products, on demand.
Showing results for 
Search instead for 
Do you mean 

No records displayed in WFS-G when using Access database

by sclow on ‎07-13-2016 05:20 AM - edited on ‎04-21-2017 06:39 AM by Technical Evangelist (873 Views)

Symptoms

After configuring a WFS-G to use Access database there is no error generating the get cababilities. The service appears healthy and in working condition. However, when searching against the WFS-G in a Geospatial Portal instance there are no search results being returned.

Diagnosis

One possible reason for this issue is that the web.config for a WFS-G service contains the section <WFSOrigPipe> to deal with, among other things, <DatabaseSpecialCharacters>. There are notes therein pertaining to either SQL or MS Jet 4.0 database. By default the SQL attributes are active and the MS Jet 4.0 database lines are commented out.

Solution

Since the WFS-G is configured to use the Access database, which is a MS Jet 4.0 database, the resolution is to comment out from the web.config the <DatabaseSpecialCharacters> lines pertaining to SQL database and activate those dealing with MS Jet 4.0 database by uncommenting them. Remember to save the web.config after the changes.

Comments
by r_ortner
on ‎09-29-2016 08:28 AM

Same problem with Oracle DB...

Contributors