Hexagon Geospatial
MENU

WebGIS

Need a push in the right direction when configuring WebMap, Portal or SDI services? Looking for hints and tips, or just looking for Ideas and information? The WebGIS discussion board is where you start those discussions, connect and share information.
Showing results for 
Search instead for 
Do you mean 
Reply
Frequent Contributor
Posts: 134
Registered: ‎04-11-2016
Accepted Solution

Display Label Web labels in WMTS - Webmap

I have an WMS service with Label Web labels. The service works perfectly in Consumer Portal. To improve the performance of the map, i have decided to go with WMTS and the WMTS will be created based on the WMS.

My question is, is it possible to bring the label web labels across to WMTS, if it is, what would be the best approach.

 

WMS - The red labels come from Label Web

 

 

WMTS - would like to bring the red labels across to this WMTS

 

Cheers

Yuan

Moderator
Posts: 255
Registered: ‎02-08-2016

Re: Display Label Web labels in WMTS - Webmap

Hello YuanGao

 

I do not see why you could not bring across the label web labels using WMTS as WMTS makes a request to the WMS service requesting a bounding box. The WMS replies with the requested bounding box (with the label web labels) which WMTS stores as a tile.

 

Have you given this a try? You may need to adjust your tile size etc.. to get the labels into the tiles.

 

Highlighted
Frequent Contributor
Posts: 134
Registered: ‎04-11-2016

Re: Display Label Web labels in WMTS - Webmap

Found out the issue.

One of the raster layers is blocking the Label Web labels for some reason. Removed that raster layer in configuration files and it starts working.

Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Service Request through our Support Portal.