Hexagon Geospatial
MENU

WebGIS

Need a push in the right direction when configuring WebMap, Portal or SDI services? Looking for hints and tips, or just looking for Ideas and information? The WebGIS discussion board is where you start those discussions, connect and share information.
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
mp
Contributor
Posts: 33
Registered: ‎05-30-2016
Accepted Solution

Exception occured when configuring Geospatial Portal instance

I have a fresh out-of-the-box Geospatial Portal 2016 installation. I can create both Geospatial Portal and Consumer Portal instances just fine. I can also configure the Consumer Portal instances without any problems. However, when clicking configure for a regular Portal instance, it throws an error:

 

ERROR SUMMARY
Exception occured.

MOST LIKELY CAUSES:
- Service instance settings were modified manually and they are not correct.
- Server settings are being modified by another user.
Configuration Service is not operating correctly.

THINGS YOU CAN TRY:
- Please ensure that service instance settings are correct.
- Please ensure that You are the only person modifying the server settings.
- Please contact the administrator.
- Please verify, if there are no errors reported in Configuration Service logs.

I have checked for similar cases on the forum here, finding: http://community.hexagongeospatial.com/t5/Support-WebGIS/Exception-in-Admin-when-configuring-an-inst... , which seemed somewhat similar. However, I have checked that anonymous access is enabled, so that should not be the problem.

This configuration service that it is suggesting not to be working correctly... where can I check this? As mentioned, this is a fresh out-of-the-box 2016 Geospatial Portal installation and a fresh Geospatial Portal instance created -> configure -> fails. 

Please advice.

Thanks.


Technical Evangelist
Posts: 1,048
Registered: ‎09-11-2015

Re: Exception occured when configuring Geospatial Portal instance

Hi Mikkel,

 

Firstly please try to look into AdminConsole service log to see what is causing the error:

C:\Program Files\Common Files\Hexagon\Administration Console Service\log

 

Jan

Jan Neumann
Post Sales Engineer Web Applications
Hexagon Geospatial

mp
Contributor
Posts: 33
Registered: ‎05-30-2016

Re: Exception occured when configuring Geospatial Portal instance

Hi Jan,

 

Thanks for the quick response. The following error is logged:

 

System.ServiceModel.FaultException`1[System.ServiceModel.ExceptionDetail]: The file '/AdminConsole/AdminPortal/GWMPubPro.aspx' does not exist. (Fault Detail is equal to An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
System.Web.HttpException: The file '/AdminConsole/AdminPortal/GWMPubPro.aspx' does not exist.
at System.Web.UI.Util.CheckVirtualFileExists(VirtualPath virtualPath)
at System.Web.Compilation.BuildManager.GetVPathBuildResultInternal(VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile, Boolean throwIfNotFound, Boolean ensureIsUpToDate)
at System.Web.Compilation.BuildManager.GetVPathBuildResultWithNoAssert(HttpContext context, VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile, Boolean throwIfNotFound, Boolean ensureIsUpToDate)
at System.Web.Compilation.BuildManager.GetVirtualPathObjectFactory(VirtualPath virtualPath, HttpContext context, Boolean allowCrossApp, Boolean throwIfNotFound)
at System.Web.Compilation.BuildManager.GetCompiledType(VirtualPath virtualPath)
at Intergraph.WebSolutions.Core.WebClient.Contr...).

 

 

And looking in: "C:\Program Files\Common Files\Hexagon\Services\AdminInstances\AdminPortal"  sure enough, the file does not exist at that location. The file does exist in the actual GS Portal instance folder though, if that information makes any difference.

This is a clean install of GS Portal 16, not an upgrade and no WebMap is installed. However, WebMap 15 (with a single GS Portal 15 instance) have been running on the server before, but have been uninstalled prior to the installation of GS Portal 16.

Regular Contributor
Posts: 246
Registered: ‎10-26-2015

Re: Exception occured when configuring Geospatial Portal instance

I experienced the same error on a clean 2016 install (no previous Hexagon s/w installed on server).

Easily fixed by copying across the file its looking for.

This looks like a defect in 2016.

mp
Contributor
Posts: 33
Registered: ‎05-30-2016

Re: Exception occured when configuring Geospatial Portal instance

[ Edited ]

Copying "GWMPubPro.aspx" from a GS Portal instance solved the issue.

 

A side effect of the issue was, that the admin.aspx site could not set the default workspace for an instance either. This is also working just fine now.

 

I would agree that this looks like a defect in GS Portal 2016.

 

Thanks Colin.

mp
Contributor
Posts: 33
Registered: ‎05-30-2016

Re: Exception occured when configuring Geospatial Portal instance

I would like to accept Colins answer as the solution, however, I can only select my own posts or Jan Neumanns answer as the solution, which is not really the case.

mp
Contributor
Posts: 33
Registered: ‎05-30-2016

Re: Exception occured when configuring Geospatial Portal instance

This still occurs in fresh GS Portal EP02 install (EP02 patch on fresh/clean Portal 2016 install)

Moderator
Posts: 245
Registered: ‎02-08-2016

Re: Exception occured when configuring Geospatial Portal instance

Hi Mikkel

 

When WebMap is installed, all the templates are in a zip files that are then unzipped to create the templates.

The templates are then copied when you create a new instance.

 

What we have found is that  this process does not always complete successfully so the templates will be missing files or be missing all together.

We have also found that those servers that have 7zip installed as the default unzip tool do not experience this problem.

 

I would suggest checking to see if the file is missing in your Template (C:\Program Files\Common Files\Hexagon\Services\Templates\Geospatial Portal/files) and if it is missing there should be a zip file in the template root directory (C:\Program Files\Common Files\Hexagon\Services\Templates\Geospatial Portal\Geospatial-Portal.zip) that you can unzip manually to the the Files directory in the template.

 

Thanks,

Marc

 

 

 

 

mp
Contributor
Posts: 33
Registered: ‎05-30-2016

Re: Exception occured when configuring Geospatial Portal instance

Hi Marc,

 

This time around, its actually a fresh/clean install of Geospatial Portal 2016 (no WebMap installed). However, this time it does not seem to be related to missing files issue, as I tried the same workaround with no luck. All installation prerequisites checks were okay and the instance it self is working without any problems. I simply couldn't configure it.

 


However, in the meantime I went over the prerequisites list again (thanks for the suggestion SCLOW) and the windows feature list. I noticed that WCF HTTP Activation was only enabled for .NET 3.5 and not .NET 4.6. Enabling this made it work.

Unfortunately the installation checks produced a false positive on that one.

 

Seems to working just fine after that change. I have configured and saved a couple of times now.

 

At least this thread is starting to be a good source for various fixes for exceptions that occurs when trying to configure Smiley Happy

 

Thanks!

Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Service Request through our Support Portal.