Hexagon Geospatial
MENU

WebGIS

Need a push in the right direction when configuring WebMap, Portal or SDI services? Looking for hints and tips, or just looking for Ideas and information? The WebGIS discussion board is where you start those discussions, connect and share information.
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Super Contributor
Posts: 301
Registered: ‎02-10-2016
Accepted Solution

Portal 16Ep04 doesn't print GTech Networks WMS

[ Edited ]

HI team,

 

Our client environment has Geospatial Portal and GTech Networks service which allows users to create WMS and WFS from GTech features.

The client has a couple of GTech Networks WFS and WMS services. These services are displayed fine in a geospatial portal instance.

 

TT.png

 

However, when we do a print on a map that has a wms feature's instances, the output print doesn't have this feature instances, it only has the base layer Open Street Map.

 

We use PhantomJS as the engine and confirm the issue with both local printer and external printer. I also enable PhantomJS logger, but I could not find anything suspious from its log location C:\Window\temp\PhantomJS. From Fiddler, I see that the Snapshot.WebClient.ashx submits the workspace that contains the WMS. From IIS log file, I notice that after clicking the print button from the dialog, there is no entry of get map request to the wms from SnapshorRedirect.WebClient.ashx (referer) with PhantomJS as the agent which we should see if the printing process working correctly.

 

I am kind of running out of ideas on how to investigate why the wms doesn't get picked up by the portal printing. Appreciate for all suggestions and insights on the problem.

 

I include the log file from portal in case it helps.

 

I also not quite sure how the map image is generated, I look into the dll Intergraph.WebSolutions.Core.WebClient.Printing and couldn't not find that part responsible for this. Would somebody explain a bit? Thank you.

 

 

Kind regards,

 

 

Regular Contributor
Posts: 246
Registered: ‎10-26-2015

Re: Portal 16Ep04 doesn't print GTech Networks WMS

The "NetWorks Portal" is a customised version of the Geospatial Portal product created by the Hexagon Safety & Infrastructure division. Have you contacted them as well about this issue as they developed the NetWorks WMS service?

 

Have you enabled any authentication/login mechanism against the NetWorks WMS service that could stop the Geospatial Portal print service from gaining access to the WMS during printing?

Super Contributor
Posts: 301
Registered: ‎02-10-2016

Re: Portal 16Ep04 doesn't print GTech Networks WMS

Hi team,

 

Some update on the issue. We tested with a third party wms and it worked fine with the printing. We also found out that if we add the working wms into the current workspace, it stopped working. We create a new workspace and it starts working again. So, the workspace somehow causes the issue but I am sure how. But, it is good that now we have the printing working.

 

Kind regards, 

Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Service Request through our Support Portal.