Hexagon Geospatial
MENU

WebGIS

Need a push in the right direction when configuring WebMap, Portal or SDI services? Looking for hints and tips, or just looking for Ideas and information? The WebGIS discussion board is where you start those discussions, connect and share information.
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Staff
Posts: 46
Registered: ‎02-16-2017
Accepted Solution

Portal WMS server name redirection at times.

While using geoportal I notice that sometimes the server of a WMS is changed to localhost from the actual server name (given in the data source) while sending GetMap requests. This is also the case with the GetFeatureInfo on the WMS service. Is there a place we configure this in the web config to swap it? For example, here below screenshot, you see that the demis is connected in the Data Sources however when I try to display,  nothing displays in the Map because the GETMAP request sent was to the localhost instead of www2.demis.nl. Same is the case for GetFeatureInfo at times it changes to localhost and fails on a WMS layter. Is there something in the config file to swap these requests. 

 

 

Staff
Posts: 46
Registered: ‎02-16-2017

Re: Portal WMS server name redirection at times.

The reason for this is becuase the GETMAP url in the capabilities document was pointing to  localhost and hence this redirection. Portal is working fine n picking the correct getMap request url. Just that the service for some reason has changed the url to localhost. And hence this problem. 

 

Vishnu

Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Service Request through our Support Portal.