Hexagon Geospatial
MENU

WebGIS

Need a push in the right direction when configuring WebMap, Portal or SDI services? Looking for hints and tips, or just looking for Ideas and information? The WebGIS discussion board is where you start those discussions, connect and share information.
Showing results for 
Search instead for 
Do you mean 
Reply
Contributor
Posts: 74
Registered: ‎03-08-2017
Accepted Solution

SDI Malformed Url Authorization

[ Edited ]

Hi there,

 

wen want to upgrade SDI from 6.1 to 2015.

 

We ran into a problem with 2015 which is a malformed URL during authorization. This problem wasn't present in version 6.1

 

In the log, I can see :

 

DEBUG Intergraph.GeoMedia.Web.SDI.Common.Utils.HTTPService.HttpRetriever [(null)] - Retrieving response from url: http://server/iserv/ows?... &bbox=-80,0219783423882,44,842921,-61,56782,52,09973

 

As you can see the bbox is malformed (contains comma as a decimal separator) thus nothing is returned.

 

If I manually replace the bbox with the correct decimal separator (

-80.0219783423882,44.842921,-61.56782,52.09973

), the image is returned fine.

 

How can I change the decimal separator.

 

Thanks

 

 

Staff
Posts: 294
Registered: ‎11-05-2015

Re: SDI Malformed Url Authorization

Most probably your computer's default culture and region settings used for the Application Pool identities set the decimal separator to the comma.

 

In the web.config's <appSettings> section, there should be a setting commented out like so:

    <!-- A setting of a decimal separator for the service. -->
    <!--add key="Intergraph.GeoMedia.Web.SDI.DecimalSeparator" value="."/-->

This setting has been exposed specifically for such cases. Uncommenting that add line should help.

Contributor
Posts: 74
Registered: ‎03-08-2017

Re: SDI Malformed Url Authorization

hbm,

 

thanks for your answer.

 

We did try this setting but it doesn't affect the spatial query.

 

If I enter "@" for instance, I can see this caracter in the log :

 

Intergraph.GeoMedia.Web.SDI.Common.SDIProFacadeInterface.SDIProCultureInfoContext [(null)] - Opened new culture info context: fr-CA, decimal separator: '@', list separator: ','

 

(Coordinate before reprojection)

 

Intergraph.GeoMedia.Web.SDI.Common.Pipes.AuthorizationPipe.AuthorizationPipe [(null)] - Authorization of request ( userContext=Intergraph.GeoMedia.Web.SDI.Common.BasePipe.SimpleUserContext, bbox=-461685@563287017,769029@029148642,-442120@216733461,791070@731887086, time=01/19/2018 12:02:53)

 

But a few lines further I can see :

 

Intergraph.GeoMedia.Web.SDI.Common.Utils.HTTPService.HttpRetriever [(null)] - Retrieving response from url=http://...&styles=&bbox=-75,0928918914689,50,7392614705889,-74,8428105397561,50,9538888533148&...

 

As you can see this setting has no effect on the problem.

 

If I leave this setting commented, I can see in the log :

 

Opened new culture info context: fr-CA, decimal separator: '.', list separator: ','

 

Which is exactly what I want but the query is still wrong.

 

I tried changing the default culture but I still have the problem.

 

Thanks for your help.

 

Contributor
Posts: 46
Registered: ‎10-13-2015

Re: SDI Malformed Url Authorization

You should try to change the cregional configiration for the user of the app pool in the windows registry

Staff
Posts: 294
Registered: ‎11-05-2015

Re: SDI Malformed Url Authorization

What Santiago wrote should work.

 

I skipped mentally the part where you mentioned authorization. After investigating a bit more I found this is unfortunately a bug in the software, as the culture info context and decimal separator setting is only happening on the main request thread. Authorization, however, opens additional threads which lack the appropriate logic to manipulate the culture info. You should open a ticket with support about that.

Contributor
Posts: 74
Registered: ‎03-08-2017

Re: SDI Malformed Url Authorization

Santiago,

 

your solution works.

 

If I may ask, how did you manage to find it ?

 

Thank you very much !

 

Contributor
Posts: 74
Registered: ‎03-08-2017

Re: SDI Malformed Url Authorization

[ Edited ]

hbm,

 

you are a staff member, make sure that this bug is corrected.

 

Thanks

Contributor
Posts: 46
Registered: ‎10-13-2015

Re: SDI Malformed Url Authorization

18 years working with GeoMedia WebMap Smiley Happy. I have had to do this for all users many times in the past for all users in a server. Now, if I have changed I try to install the OS in English.

 

I have been trying along these years that that the ofcicial decimal separator was the point (more easy) in all languages and the units was the International System (more logical) and this was saved all many millons of euros, dollars, pounds, yens,...but it is impossible.

Moderator
Posts: 245
Registered: ‎02-08-2016

Re: SDI Malformed Url Authorization

[ Edited ]

Hello Olyster.

 

Did you want me to log a ticket on your behalf? or is the solution /  work around provided acceptable?

 

 

Thank You,

Marc

Contributor
Posts: 74
Registered: ‎03-08-2017

Re: SDI Malformed Url Authorization

Marc,

 

this is an obvious bug and it has been recognized by hbm.

 

A customer shouldn't have to edit the registry to make a program work the way it should. This bug should be corrected.

 

As a customer, I shouldn't be responsible for opening tickets or bug reports when staff members are aware of a bug. It is your software and I'm sure you want it to be better.

 

In the present case, a customer found a bug and another customer provided the solution to make your software work. This is the best scenario for you.

 

On my side, I don't have anything to do : you have everything you need in hand to take the appropriate actions to correct your software.

 

Thank you.

Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Service Request through our Support Portal.