Hexagon Geospatial
MENU

WebGIS

Need a push in the right direction when configuring WebMap, Portal or SDI services? Looking for hints and tips, or just looking for Ideas and information? The WebGIS discussion board is where you start those discussions, connect and share information.
Showing results for 
Search instead for 
Do you mean 
Reply
Super Contributor
Posts: 389
Registered: ‎10-12-2015
Accepted Solution

Text / Label location changes and disappears

Have observed variations on following a couple of times now with GeoMedia WebMap 2018, so thought I'd post to hopefully save some grief.

 

Map is published to WMS or WMPS service that includes label or text legend entries.

WMS or WMPS is displayed using PNG or JPEG.

 

The location of labels in the map shifts around, disappears, then displays correctly again before shifting again.

 

Exactly the same map request is made each time. 

e.g. for an wms, request such as http://MyServer.MyOrg.com/WMSLabelIssue/service.svc/get?SERVICE=WMS&REQUEST=GetMap&VERSION=1.3.0&LAY... is run in browser. Browser is refreshed (F5) and labels display in different location or disappear as new, identical, WMS getmap requests are made.

 

e.g. First request might show labels in correct location such as

Label01.jpg

Next (identical) request shows the labels all offset in wrong location such as

label02.jpg

Next (identical) request shows no labels at all such as 

label03.jpg

Keep making requests and get different permentations, some labels showing, some not, reappear, disappear etc.

Super Contributor
Posts: 389
Registered: ‎10-12-2015

Re: Text / Label location changes and disappears

Problem:

Some legend entries use font ‘Arial Narrow’ and some legend entries uses ‘Arial Black’.

  1. Font ‘Arial Narrow’ is not installed on the server that GeoMedia WebMap is installed/running on.
    Leads to problems.
  2. Font ‘Arial Black’ is known to be problematic. 
    Basically some fonts don’t meet the font standard/naming rules and WebMap 2018 has issues with those non-conformant fonts. Most applications are forgiving of those fonts. Interestingly some core OS fonts such as Arial Black don’t strictly meet the standard so WebMap has problems with them. Normally it is custom fonts that don’t meet the rules.

 

Solution: Change to a different font that is installed on the WebMap server and meets font standard/naming rules.

 

For testing I changed all legend entries that used 'Arial Narrow' to use ‘Arial’ instead and changed the legend entries that used 'Arial Black' to use ‘Corbel’. It then worked correctly.

 

 

For Arial Narrow, bit of googling turned up following:

On some Windows systems, such as Windows 7 / 64-bit, recent releases, and perhaps even on earlier similar releases (we don't know exactly), the Monotype Arial Narrow font (a TrueType font) is not included by default with the operating system. It is licensed and included with MS Office, and other apps, but not as part just of the OS in itself, so if you didn't purchase MS Office, or if you have a very stripped down basic configuration of Windows, then there's a chance that the font is not present on your system.

Following seems to support that – list of products Arial Narrow is deployed with - https://docs.microsoft.com/en-us/typography/font-list/arial-narrow

Staff
Posts: 332
Registered: ‎02-04-2016

Re: Text / Label location changes and disappears

Hi Shaun,

 

Does the permentation correlate to the number of mapsvr.exe running ?

 

And I believe the Jira you mentioned (Ariel Black issue) is resolved in v16.6

 

Thanks

 

Frank

 

Super Contributor
Posts: 389
Registered: ‎10-12-2015

Re: Text / Label location changes and disappears

Great news re Arial Black and 16.6.

 

I'm running 2 Map Servers. With 2 map servers I'll see one map correct, one map with labels offset and one with no labels.

I changed to 1 map server and map sequence was 'No Labels', 'Labels offset', 'No Labels', 'No Labels', 'Labels Offset (different location from original offset)', 'No Labels', 'No Labels', 'Correct Labels', 'No Labels'.

So does not appear to be casual correlation.

 

I didn't spend time looking at legends with only 'Arial Black' and only 'Arial Narrow' to see if there is any cross contamination.

Super Contributor
Posts: 389
Registered: ‎10-12-2015

Re: Text / Label location changes and disappears

And there was also semi-related issue where letter spacing of a label would be incorrect in some scenarios. Fixed in WebMap 2018 update 2 from memory.

Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Service Request through our Support Portal.