Hexagon Geospatial
MENU

WebGIS

Need a push in the right direction when configuring WebMap, Portal or SDI services? Looking for hints and tips, or just looking for Ideas and information? The WebGIS discussion board is where you start those discussions, connect and share information.
Showing results for 
Search instead for 
Do you mean 
Reply
Contributor
Posts: 74
Registered: ‎03-08-2017
Accepted Solution

WFS version with portal geomedia webmap

Hi,

 

we have this setup : portal --> facade --> WFS server

 

In portal, only wfs version 1.1.0 is available with "detect automatically".

 

If we select 1.1.0, everything works fine. If we choose "detect automatically", the request sent to the server is :

 

https://server/serviceName/service.svc/get?request=GetCapabilities&service=WFS&acceptversions=2.0.0,1.1.0

 

As you can see, acceptversions is 2.0.0, 1.1.0 that makes the service responding in version 2.0.0 which we don't want.

 

Is it possible de reverse the order (1.1.0, 2.0.0) or make sure that version 2.0.0 is not part of this parameter ?

 

Thanks

Staff
Posts: 190
Registered: ‎02-02-2016

Re: WFS version with portal geomedia webmap

Moving this thread to the Support WebGIS board so that it reaches the appropriate audience for GeoMedia WebMap and Portal questions.

Technical Evangelist
Posts: 1,034
Registered: ‎09-11-2015

Re: WFS version with portal geomedia webmap

Hi Olyster,

 

You can create a service quirk for your WFS in Portal to exclude specific versions:

<serviceQuirk serviceType="WFS" urlPattern="yourWFSurl">
   <excludeVersions>
       <add key="2.0.0" value="true"/>
   </excludeVersions>
</serviceQuirk>

 

Best Regards,

Jan

Jan Neumann
Post Sales Engineer Web Applications
Hexagon Geospatial

Contributor
Posts: 74
Registered: ‎03-08-2017

Re: WFS version with portal geomedia webmap

Hi jan,

 

thanks for your answer.

 

I think we are on the right path.

 

The element "excludeVersions" is available starting with which version ?

 

With portal 2015 I get "Unrecognized element 'excludeVersions'."

 

Thanks for your help.

Technical Evangelist
Posts: 1,034
Registered: ‎09-11-2015

Re: WFS version with portal geomedia webmap

[ Edited ]

As per the backlog, it should be available since 2015 EP04 and initial 2016 release. I tested it on 2016 EP04 where it worked fine.

It's currently documented only in the web.config file of Portal.

 

Jan Neumann
Post Sales Engineer Web Applications
Hexagon Geospatial

Contributor
Posts: 74
Registered: ‎03-08-2017

Re: WFS version with portal geomedia webmap

jan,

 

thanks for you answer.

 

I confirm that the parameter acceptVersions now contains 1.1.0 only.

 

Thanks for your help.

Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Service Request through our Support Portal.