Hexagon Geospatial
MENU

WebGIS

Need a push in the right direction when configuring WebMap, Portal or SDI services? Looking for hints and tips, or just looking for Ideas and information? The WebGIS discussion board is where you start those discussions, connect and share information.
Showing results for 
Search instead for 
Do you mean 
Reply
Contributor
Posts: 26
Registered: ‎05-10-2017
Accepted Solution

WMS service and attributes

[ Edited ]
  •  
    Hello!
    The object attributes contain a hyperlink to the file. Objects could be found in the WMS service, but hyperlink not active. 
     
    How to make a hyperlink open?
     
     

    Thank you

     

     
Anna
Technical Evangelist
Posts: 1,016
Registered: ‎09-11-2015

Re: WMS service and attributes

Hi Anna,

 

What type of hyperlinks do you use? Can you show an example?

Have you set the hyperlink field as hypertext in the GDO metadata?

Untitled.png

 

Thanks,

Jan

Jan Neumann
Post Sales Engineer Web Applications
Hexagon Geospatial

Contributor
Posts: 26
Registered: ‎05-10-2017

Re: WMS service and attributes

Hi, Jan.

I'm just making a hyperlink. She works in GeoMedia. It does not work on the portal in the WMS service.

Anna
Staff
Posts: 300
Registered: ‎02-04-2016

Re: WMS service and attributes

Hi Anna,

 

I have just worked on a WMS hyperlink ticket, and the finding is that 16.x WMS attribute hyperlink is enabled under Geospatial Portal v16.5's GetFeatureInfo command.

 

What version of WebMap/WMS are you using ?

 

Regards,

 

Frank

 

Contributor
Posts: 26
Registered: ‎05-10-2017

Re: WMS service and attributes

Hi Frank,

I use WebMap 16.5x.

How did you activate the hyperlink, when configuring the service?

 

Anna

Anna
Staff
Posts: 300
Registered: ‎02-04-2016

Re: WMS service and attributes

Hi Anna,

 

If your WMS feature's hyperlink is enabled under GeoMedia, then make sure you select "text/html" under FeatureInfo format when you connect to this WMS under the Portal's New Data Source interface.

 

Thanks

 

Frank

Contributor
Posts: 26
Registered: ‎05-10-2017

Re: WMS service and attributes

Hi Frank,

 

Thank you, it works.

Anna
Contributor
Posts: 26
Registered: ‎05-10-2017

Re: WMS service and attributes

Hi Frank,

When I connect to WMS under the interface of the new portal data source, I select “text / html” in the FeatureInfo format, when selecting information on the object, all the service objects appear in the data window. How to fix it?

Anna
Staff
Posts: 300
Registered: ‎02-04-2016

Re: WMS service and attributes

Hi Anna,

 

Portal will display all available WMS feature attributes.  GeoMedia will do the same as well.

 

If the WMS service is created by WebMap, you can customize how WMS attributes are reported in the service source with the WebMap Publisher Administrator's "Display Fields" command:

https://hexagongeospatial.fluidtopics.net/reader/VN16UWekLH1Ie76alrgScw/C0KfIuLOCmWtkx6mZ6NJwQ

 

Hope this helps.

 

Regards,

 

Frank

 

 

Contributor
Posts: 26
Registered: ‎05-10-2017

Re: WMS service and attributes

[ Edited ]

Hi Frank,
I'm not talking about the number of attributes, but about the fact that when I select the text / html WMS service format, I click on show information about the object and see at the same time all the objects of the service in the data window, although I chose one object on the map.

Next, from the entire list, I select the necessary object and see its attributes. To open a hyperlink, I need to select it and click the right mouse button to open the menu, then I choose to open a hyperlink. It turns out not very convenient option.

Anna
Polls
Please register to vote
Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Service Request through our Support Portal.