Hexagon Geospatial
MENU

WebGIS

Need a push in the right direction when configuring WebMap, Portal or SDI services? Looking for hints and tips, or just looking for Ideas and information? The WebGIS discussion board is where you start those discussions, connect and share information.
Showing results for 
Search instead for 
Do you mean 
Reply
Contributor
Posts: 43
Registered: ‎05-30-2016

wms in geomedia webmap 16.5 run in https - getmap http

We have a wms set up with geomedia webmap 16.5 

we are running everything in https.

the server has a valid ssl certificate and we can run the getcapabilities document in https without a problem.

But when using the wms inside a portal, the get map is run with the local address in http. And therefore the data is not displayed.

 

How can this be changed?

Regular Contributor
Posts: 246
Registered: ‎10-26-2015

Re: wms in geomedia webmap 16.5 run in https - getmap http

Within the cWMS apabilities document what protocol (HTTP or HTTPS) is specified within the HTTP Get sections?

Contributor
Posts: 43
Registered: ‎05-30-2016

Re: wms in geomedia webmap 16.5 run in https - getmap http

https but the local address, see below.
 
where can this be changed?
 
<GetCapabilities>
<Format>text/xml</Format>
<DCPType>
<HTTP>
<Get>
<OnlineResource xlink:href="https://xxx.xxxx.local/..." xlink:type="simple"/>
</Get>
<Post>
<OnlineResource xlink:href="https://xxx.xxx.local/..." xlink:type="simple"/>
</Post>
</HTTP>
</DCPType>
</GetCapabilities>
<GetMap>
<Format>image/png</Format>
<Format>image/jpeg</Format>
<Format>image/svg+xml</Format>
<DCPType>
<HTTP>
<Get>
<OnlineResource xlink:href="https://xxx.xxxx.local/..." xlink:type="simple"/>
</Get>
<Post>
<OnlineResource xlink:href="https://xxx.xxxx.local/..." xlink:type="simple"/>
</Post>
</HTTP>
</DCPType>
</GetMap>
Regular Contributor
Posts: 246
Registered: ‎10-26-2015

Re: wms in geomedia webmap 16.5 run in https - getmap http

Have you configured the a Hostname alias in the Geospatial Server Administration Console with the public facing DNS of the web server?

 

If you haven't yet done this, you need to recycle the WMS IIS AppPool after you enable the hostname alias in order for the WMS to detect the changes.

Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Service Request through our Support Portal.