Who Me Too'd this solution

Showing results for 
Search instead for 
Do you mean 
Anonymous
Posts: 0
Re: Displaying areas in acres and projection coordinates in survey feet using icons in gwmpub.aspx

Hi,

 

First off, I'm not sure that survey_ft is supported yet for measurements in a Portal Application.  A CR-Ehancement could be logged to add support for that unit type. The supported units are (from the fluidtopics online documentation):

 

Available units are:

For linear measurements:

  • m
  • km
  • ft
  • yd
  • mi

For areal measurements:

  • m2
  • km2
  • ft2
  • yd2
  • mi2
  • are
  • ha
  • acre

 

This is what worked for me.  Created a new v 2016, EP01, Publisher Portal application so now I have a Portal application and a WMPS application.  Edited the Web.Config of the Portal application and set the enabledunits element tag as so:

 

<ui dblClickTimeout="400" settingsRequireConfirmation="true" systemOfMeasurement="imperial" enabledUnits="ft, ft2, acre">

 

Then I went to IIS Manager and restarted IIS.  When a change is made in a Web.Config file, IIS must be reset in order to "see" the change.  You can also open a command prompt window and key-in the command of:   iisreset.   There probably is another, easier way to do this, but this workflow does work successfully.

 

Then I opened the portal application and displayed the WMPS MapWindow1.  I then did an Area measurement creating a rectangular area with 4 points and the distance on the lines is show in ft, and the area of the rectangle is shown in acres. 

 

In your case, be sure you have lower case for the word "imperial" and then try with just the units you want omitting survey_ft. I also set the settingsRequireConfirmation parameter to "true" because in my intial testing on version 2015, the desired units were not displayed until I changed that value from "false" to "true". 

 

Please try these changes on your end in the Web.Config file of the Portal application, reset IIS, and then retest the measurements to see if the values of ft and acres are displaying. 

 

Hope this helps.

 

Kind Regards,

 

Carolyn

 

 

View solution in original post

Who Me Too'd this solution