Who Me Too'd this topic

Showing results for 
Search instead for 
Do you mean 
New Contributor
Posts: 4
Registered: ‎05-29-2018
Accepted Solution
Error when importing Landsat data (5, 7, or 8)

Hi, I have downloaded Landsat 5 and 7 data from USGS GloVis and am running the Import Data utility in IMAGINE 2018. When the Process List says it's "Acquiring Licenses", I get an error popup that just says "Args". Then it continues on, but throws the same error for every .img file I have it process. 

 

I started the Session Log the last time I ran it, and when I click "OK" on the error dialog, it writes out these 4 lines:

05/04/19 10:41:14 SessionMgr(11596): ERROR: #587 from efnp_FileNameGetNamePart
05/04/19 10:41:14 SessionMgr(11596): ERROR: efnp_FileNameGetNamePart fail
05/04/19 10:41:14 SessionMgr(11596): ERROR: #2403 from efnp_FileNameGet
05/04/19 10:41:14 SessionMgr(11596): ERROR: Args

 

The only thing I can think of that it was squawking at was maybe spaces and/or special characters in the path to the file I was originally using, which is this:

c:/users/alask/documents/phd research/kbs/landsat scenes/1999 (corn)/

 

So I changed the folders to remove spaces and the parentheses. I also updated the paths in the Default Data Directory and Default Output Directory in my Preferences. However, it is still remembering this old path (above), and it still appears in the session log even when I just run everything from and to the desktop. I have shut the software, and even my computer, down, and it still does this. So it's got the old path permanently cached somewhere.

 

I don't even know if that's the problem, but it seems like a first place to look. Trouble is, I don't know where to look. Or what else might be the problem if this isn't it.

 

Any ideas?

 

Who Me Too'd this topic